您的位置:首页 > 其它

POJ-2406(Power Strings)(KMP())

2016-04-11 21:29 316 查看
POJ-2406(Power Strings)(KMP())

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.


Sample Output

1
4
3


Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed. 

注:这题主要是找最小循环节。而最小循环节长度为:len-nest(len)(即;len-j (j为getnest中跳出循环后,j的值))

做完这道题可以再做一下poj1961

My  solution:

/*2016..4.11*/

#include<cstring>
#include<cstdio>
char c[1001000];
int nest[1001000];
void getnest()
{
int i=0,j=-1,k,len,h;
len=strlen(c);
nest[i]=j;
while(i<len)
{
if(j==-1||c[i]==c[j])
{
i++;
j++;
nest[i]=j;
}
else
j=nest[j];
}
k=i-j;//k为最小循环节长度
if(i%k==0)
{
h=i/k;//最小循环节个数
printf("%d\n",h);
}
}
int main()
{
int i,j,k;
while(scanf("%s",c)!=EOF)
{
if(c[0]=='.')
break;
getnest();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: