您的位置:首页 > 其它

ZOJ 3777 - Problem Arrangement

2016-04-11 16:23 260 查看
B - Problem Arrangement
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld
& %llu
Submit Status Practice ZOJ
3777

Description

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take
more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th
problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation
needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an
acceptable permutation, output "No solution" instead.

Sample Input

2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4


Sample Output

3/1
No solution


状压DP,dp[i][j][k]表示选第i个数时,状态为j,和为k的情况数,预处理一下0~(1<<12)-1二进制表示1的数目。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <bitset>
#include <algorithm>
#include <queue>
using namespace std;

#define N 15
#define INF 0x3f3f3f3f
#define LL long long

int a

,fac
;
int cnt[4500];

int dp[2][4500][505];
int gcd(int a,int b){
if (b==0) return a;
else return gcd(b,a%b);
}

void init(){
fac[0] = 1;
for (int i=1;i<N;i++) fac[i] = fac[i-1]*i;
memset(cnt,0,sizeof(cnt));
for (int i=0;i<(1<<12);i++){
int u=i;
while (u){
if (u&1)
cnt[i]++;
u>>=1;
}
}
}

int main(){
int T;
scanf("%d",&T);
init();
while (T--){
int n,m;
scanf("%d%d",&n,&m);
for (int i=0;i<n;i++)
for (int j=0;j<n;j++) scanf("%d",&a[i][j]);
memset(dp,0,sizeof(dp));
for (int i=0;i<n;i++)
dp[0][1<<i][min(a[0][i],m)]=1;
for (int i=1;i<n;i++){
int now=i&1,last=(i-1)&1;
for (int j=0;j<(1<<n);j++){
if (cnt[j]!=i)
continue;
for (int k=0;k<n;k++){
if (j&(1<<k))
continue;
for (int l=0;l<=m;l++)
dp[now][j|(1<<k)][min(m,l+a[i][k])]+=dp[last][j][l];
}
}
}

int fm=fac
;
int fz=dp[(n-1)&1][(1<<n)-1][m];
if (fz==0){
printf("No solution\n");
}else{
int g=gcd(fm,fz);
printf("%d/%d\n",fm/g,fz/g);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: