您的位置:首页 > 产品设计 > UI/UE

1007. Maximum Subsequence Sum (25)

2016-04-11 15:00 435 查看
Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence
{ -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence
is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10

-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

IDEA

1.本题考查子序列最大和,求出每个子序列的和,记录最大和,其开始数与结束数

2.两次遍历,时间复杂度O(k^2)

CODE

#include<iostream>
using namespace std;
int main(){
int k;
cin>>k;
int a[10001];
for(int i=0;i<k;i++){
cin>>a[i];
}
int sum=-1,start=a[0],end=a[k-1];
for(int i=0;i<k;i++){
int tmp_sum=0;
for(int j=i;j<k;j++){
tmp_sum+=a[j];
if(tmp_sum>sum){
sum=tmp_sum;
start=a[i];
end=a[j];
}
}
}
if(sum<=0){
cout<<0;
}else{
cout<<sum;
}
cout<<" "<<start<<" "<<end;
return 0;
}




注:有遍历一次就得出结果的大神算法,时间复杂度O(k), 附上大神的算法,共同学习进步


#include<iostream>
using namespace std;
int main(){
int k;
cin>>k;
int a[10001];
for(int i=0;i<k;i++){
cin>>a[i];
}
int sum=0,start=0,end=k-1;
int temp=0,tempi=0,tempj=0;
for(int i=0;i<k;i++){
if(temp>=0){
temp+=a[i];
tempj=i;
}else{
temp=a[i];
tempi=i;
tempj=i;
}
if(temp>sum||(temp==0&&end==k-1)){
sum=temp;
start=tempi;
end=tempj;
}
}
cout<<sum<<" "<<a[start]<<" "<<a[end];

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: