您的位置:首页 > 其它

HDU 1579 Function Run Fun(记忆化搜索)

2016-04-10 22:00 423 查看

Function Run Fun

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2519 Accepted Submission(s): 1324



[align=left]Problem Description[/align]
We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:

1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:

w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

[align=left]Input[/align]
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

[align=left]Output[/align]
Print the value for w(a,b,c) for each triple.

[align=left]Sample Input[/align]

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1


[align=left]Sample Output[/align]

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


[align=left]Source[/align]
冬练三九之一

/*
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

数组开三维22就行

*/
#include<iostream>
#include <string.h>
using namespace std;
int num[22][22][22];
int w(int a,int b,int c){
if(a<=0||b<=0||c<=0)
return 1;
if(a>20||b>20||c>20)
return num[20][20][20]=w(20,20,20);
if(num[a][b][c]!=-1)
return num[a][b][c];
if(a<b&&b<c)
return num[a][b][c]=w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c);
return num[a][b][c]=w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1);
}
int main()
{
int a,b,c;
memset(num,-1,sizeof(num));
while(cin>>a>>b>>c){
if(a==-1&&b==-1&&c==-1)
break;
cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<w(a,b,c)<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: