您的位置:首页 > 其它

hdu 3795 Billboard(线段树)

2016-04-10 20:26 260 查看
Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu,
and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard,
output "-1" for this announcement.

Sample Input

3 5 5
2
4
3
3
3


Sample Output

1
2
1
3
-1


solution:

以每一行为一个节点,建立线段树,储存区间内可以放入的最大广告牌长度。每次优先查询左节点(即优先查询最上面的行数)。

#include<cstdio>
#include<algorithm>
using namespace std;
#define ls t<<1
#define rs (t<<1)|1
const int maxn = 200010;
int h, w, n,wi;
struct node{
int len, l, r;
}tree[maxn*4];
void build(int l, int r, int t)
{
tree[t].l = l;
tree[t].r = r;
tree[t].len = w;
if (l == r)return;
build(l, (l + r) / 2, ls);
build((l + r) / 2 + 1, r, rs);
}
void update(int t)
{
if (t == 1)return;
t = t / 2;
tree[t].len = max(tree[ls].len, tree[rs].len);
update(t);
}
int Query(int t, int ww)
{
if (tree[t].l == tree[t].r&&tree[t].len >= ww)
{
tree[t].len -= ww;
update(t);
return tree[t].l;
}
if (tree[ls].len >= ww)Query(ls, ww);
else Query(rs, ww);
}
int main()
{
while (~scanf("%d%d%d", &h, &w, &n))
{
h = min(h, n);
build(1, h, 1);
for (int i = 0; i < n; i++)
{
scanf("%d", &wi);
if (tree[1].len < wi)printf("-1\n");
else  printf("%d\n",Query(1, wi));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: