您的位置:首页 > 其它

微软 Font Size

2016-04-10 14:38 232 查看
描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven’s phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)

So here’s the question, if Steven wants to control the number of pages no more than P, what’s the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, … aN, indicating the number of characters in each paragraph.

For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入

2

1 10 4 3

10

2 10 4 3

10 10

样例输出

3

2

/**
* 每页至少显示一个字, size=min(w,h)
* 每行显示字数row=w/size,每页显示行数col=h/size
* 每段包含p个字,则每段占行数lines=(p+row-1)/row(向下取整)
* @author ustc-lezg
*/
#include <stdio.h>

int getMaxSize(int n, int p, int w, int h, int *num) {
int min = w < h ? w : h;
int row,col,lines;
for (int size = min; size > 0; --size) {
row = w / size;
col = h / size;
lines = 0;
for (int i = 0; i < n; ++i) {
lines += (num[i] + row - 1) /row;
}
if (lines <= col * p) {
return size;
}
}
return 1;
}

int main() {
int num[1002];
int t, n, w, h, p;
scanf("%d", &t);
while (t--) {
scanf("%d %d %d %d", &n, &p, &w, &h);
for (int i = 0; i < n; ++i) {
scanf("%d", &num[i]);
}
printf("%d\n",getMaxSize(n,p,w,h,num));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  微软