您的位置:首页 > 其它

jrMz and angles

2016-04-09 20:59 337 查看
jrMz and angles

 Accepts: 758

 Submissions: 1198

 Time Limit: 2000/1000 MS (Java/Others)

 Memory Limit: 65536/65536 K (Java/Others)

Problem Description

jrMz has two types of angles, one type of angle is an interior angle of nnn-sided regular polygon, and the other type of angle is an interior angle of mmm-sided regular polygon. jrMz wants to use them to make up an angle of 360 degrees, which means, jrMz needs to choose some or none of the angles which belong to the first type and some or none of the angles which belong to the second type so that the sum value of the angles chosen equals 360 degrees. But jrMz doesn’t know whether it is possible, can you help him?

Input

The first line contains an integer T(1≤T≤10)T\left(1\leq T\leq10\right)T(1≤T≤10)——The number of the test cases. For each test case, the only line contains two integers n,m(1≤n,m≤100)n,m\left(1\leq n,m\leq100\right)n,m(1≤n,m≤100) with a white space separated.

Output

For each test case, the only line contains a integer that is the answer.

Sample Input

3

4 8

3 10

5 8

Sample Output

Yes

Yes

No

Hint

In test case 1, jrMz can choose 1 angle which belongs to the first type and 2 angles which belong to the second type, because 90+135+135=360.

In test case 2, jrMz can choose 6 angles which belong to the first type, because6\times60=360.

In test case 3, jrMz can’t make up an angle of 360 degrees.

水题:直接代码

#include<iostream>
using namespace std;
int main()
{
int t,n,m;
cin>>t;
while(t--)
{
cin>>n>>m;
int flag=1;
double x=180-360.0/n,y=180-360.0/m;
for(int i=0;i<=100;i++)
{
for(int j=0;j<100;j++)
if(x*i+y*j==360)
{
cout<<"Yes"<<endl;
//cout<<i<<" "<<j<<endl;
flag=0;
break;
}
if(!flag)break;
}
if(flag)cout<<"No"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: