您的位置:首页 > 运维架构

poj 3050 hopscotch

2016-04-08 21:01 260 查看
果然啊 遇到DFS就不会 要多加练习啊

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.
Input

* Lines 1..5: The grid, five integers per line
Output

* Line 1: The number of distinct integers that can be constructed
Sample Input
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1</pre>
Sample Output
15
HintOUTPUT DETAILS:
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.
#include <cstdio>
#define MAX_N 10
using namespace std;
int graph[MAX_N][MAX_N];
bool vis[10000000];
int make[6];
int dx[4] = {0,0,-1,1};
int dy[4] = {-1,1,0,0};

int ans = 0;
void dfs(int x,int y,int step)
{
if(step==6)
{
int num=0;
for(int i=0;i<6;i++)
{
num*=10;
num+=make[i];
}
if(!vis[num])
{
vis[num]=true;
ans++;
}
return;
}
make[step]=graph[x][y];

for(int i = 0;i < 4;i++)
{
int nx = x + dx[i];
int ny = y + dy[i];
if(nx >= 0 && nx < 5 && ny >= 0 && ny < 5)
{
dfs(nx,ny,step+1);
}
}
}

int main()
{
for(int i = 0;i < 5; i++)
{
for(int j = 0;j < 5; j++)
{
scanf("%d",&graph[i][j]);
}
}
for(int i = 0;i < 5; i++)
{
for(int j = 0;j < 5; j++)
{
dfs(i,j,0);
}
}
printf("%d\n",ans);

return 0;
}


#include <iostream>
#include <set>
using namespace std;
const int dx[4]={-1,0,1,0};
const int dy[4]={0,1,0,-1};
int pos[6][6];
set<int> st;
void dfs(int i,int j,int value,int num)
{
if(num==6)
{
st.insert(value);
return;
}
for(int k=1;k<=4;k++)
{
int nx=i+dx[k];
int ny=j+dy[k];
if(nx>=1&&nx<=5&&ny>=1&&ny<=5)
{
num++;
dfs(nx,ny,10*value+pos[nx][ny],num);
num--;
}

}
}

int main()
{
for(int i=1;i<=5;i++)
for(int j=1;j<=5;j++)
cin>>pos[i][j];
for(int i=1;i<=5;i++)
for(int j=1;j<=5;j++)
dfs(i,j,pos[i][j],1);
cout<<st.size()<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: