您的位置:首页 > 其它

Just a Hook

2016-04-08 13:37 309 查看
区间更新,区间求和,对线段建树,维护区间和

http://acm.hdu.edu.cn/showproblem.php?pid=1698


Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 25609    Accepted Submission(s): 12789


Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.

For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.

Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents
the golden kind.

 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 

Sample Input

1
10
2
1 5 2
5 9 3

 

Sample Output

Case 1: The total value of the hook is 24.

 

Source

2008 “Sunline Cup” National Invitational Contest

 
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <cmath>
#include <string>
#include <iostream>
#include <string>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define LL long long
const int SIZE=1e5+10;
using namespace std;
struct sge{
int sum;
int lazy;
}a[SIZE<<2];
void pushup(int rt){
a[rt].sum=a[rt<<1].sum+a[rt<<1|1].sum;
}
void pushdown(int l,int r,int rt){
if(a[rt].lazy){
int m=r-l+1;
a[rt<<1].sum=(m-m/2)*a[rt].lazy;
a[rt<<1|1].sum=m/2*a[rt].lazy;
a[rt<<1].lazy=a[rt<<1|1].lazy=a[rt].lazy;
a[rt].lazy=0;
}
}
void build(int l,int r,int rt){
a[rt].lazy=0;
if(l==r){
a[rt].sum=1;
return;
}
int m=(l+r)>>1;
pushdown(l,r,rt);
build(lson);
build(rson);
pushup(rt);
}
void update(int L,int R,int c,int l,int r,int rt){
if(L<=l&&r<=R){
a[rt].sum=c*(r-l+1);
a[rt].lazy=c;
return;
}
pushdown(l,r,rt);
int m=(l+r)>>1;
if(L<=m)update(L,R,c,lson);
if(R>m)update(L,R,c,rson);
pushup(rt);
}
int main()
{
int T,n,q,x,y,z;
scanf("%d",&T);
for(int cas=1;cas<=T;cas++){
scanf("%d%d",&n,&q);
build(1,n,1);
for(int i=0;i<q;i++){
scanf("%d%d%d",&x,&y,&z);
update(x,y,z,1,n,1);
}
printf("Case %d: The total value of the hook is %d.\n",cas,a[1].sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: