您的位置:首页 > 产品设计 > UI/UE

LightOJ - 1369 Answering Queries (规律)

2016-04-07 21:19 330 查看
原文链接:http://www.cnblogs.com/soTired/p/5365509.html Answering Queries
Time Limit: 3000MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Submit Status

Description

The problem you need to solve here is pretty simple. You are give a function f(A, n), where A is an array of integers and n is the number of elements in the array. f(A, n) is defined as follows:

long long f( int A[], int n ) { // n = size of A

    long long sum = 0;

    for( int i = 0; i < n; i++ )

        for( int j = i + 1; j < n; j++ )

            sum += A[i] - A[j];

    return sum;

}

Given the array A and an integer n, and some queries of the form:

1)      0 x v (0 ≤ x < n, 0 ≤ v ≤ 106), meaning that you have to change the value of A[x] to v.

2)      1, meaning that you have to find f as described above.

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case starts with a line containing two integers: n and q (1 ≤ n, q ≤ 105). The next line contains n space separated integers between 0 and 106 denoting the array A as described above.

Each of the next q lines contains one query as described above.

Output

For each case, print the case number in a single line first. Then for each query-type "1" print one single line containing the value of f(A, n).

Sample Input

1

3 5

1 2 3

1

0 0 3

1

0 2 1

1

Sample Output

Case 1:

-4

0

4

Source

Problem Setter: Hasnain Heickal Jami Special Thanks: Jane Alam Jan   细节+ 规律,
#include <cstdio>
#define N 100000+100
typedef long long LL;
LL a
;
int main()
{
int t, Q=1; scanf("%d", &t);
while(t--)
{
int n, q; scanf("%d%d", &n, &q);
for(int i=0; i<n; i++)
scanf("%lld", &a[i]);
LL getSum=0;
//for(int i=0; i<n; i++)
//    getSum+=(n-1-i*2)*a[i];
LL A=n-1, b=0;
for(int i=0; i<n; i++)
{
if(A <0|| b> n)
continue;
getSum +=A*a[i]-b*a[i];
A--; b++;
}
int firNum;
printf("Case %d:\n", Q++);
while(q--)
{
scanf("%d", &firNum);
if(firNum==1)
printf("%lld\n", getSum);
else
{
int posi; LL modify;
scanf("%d%lld", &posi, &modify);
LL wc=modify-a[posi];
getSum=getSum+(n-1-2*posi)*wc;
a[posi]=modify;  //更新必须要有 !!!!! ;
}
}
}
return 0;
}

 

 

转载于:https://www.cnblogs.com/soTired/p/5365509.html

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: