您的位置:首页 > 其它

2010年山东省第一届ACM大学生程序设计竞赛:Hello World!

2016-04-06 19:29 471 查看

Hello World!


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

We know that Ivan gives Saya three problems to solve (Problem F), and this is the first problem.

“We need a programmer to help us for some projects. If you show us that you or one of your friends is able to program, you can pass the first hurdle.

I will give you a problem to solve. Since this is the first hurdle, it is very simple.”

We all know that the simplest program is the “Hello World!” program. This is a problem just as simple as the “Hello World!”

In a large matrix, there are some elements has been marked. For every marked element, return a marked element whose row and column are larger than the showed element’s row and
column respectively. If there are multiple solutions, return the element whose row is the smallest; and if there are still multiple solutions, return the element whose column is the smallest. If there is no solution, return -1 -1.

Saya is not a programmer, so she comes to you for help

Can you solve this problem for her?

输入

The input consists of several test cases.

The first line of input in each test case contains one integer
N (0<N≤1000), which represents the number of marked element.

Each of the next
N lines containing two integers r and c, represent the element’s row and column. You can assume that 0<r, c≤300. A marked element can be repeatedly showed.

The last case is followed by a line containing one zero.

输出

For each case, print the case number (1, 2 …), and for each element’s row and column, output the result. Your output format should imitate
the sample output. Print a blank line after each test case.

示例输入

3
1 2
2 3
2 3

0


示例输出

Case 1:
2 3
-1 -1
-1 -1


提示

来源

2010年山东省第一届ACM大学生程序设计竞赛
#include <iostream>
using namespace std;
int map[301][301];
int y[1001][2];
void find(int r,int c)
{
int tag=0;
for(int i=r+1; i<301; i++)
{
for(int j=c+1; j<301; j++)
{

if(map[i][j]==1&&tag==0)
{
tag=1;
cout<<i<<" "<<j<<endl;
break;
}
}
}
if(tag==0)
{
cout<<-1<<" "<<-1<<endl;
}
}
int main()
{
int t,g=0,loop=0;
while(cin>>t)
{

if(t==0)
{
break;
}
else
{
int m=0;
for(int i=0; i<301; i++)
{
for(int j=0; j<301; j++)
{
map[i][j]=0;
}
}
int  q=t;
g++;
while(t--)
{
loop++;
int r,c;
cin>>r>>c;
m++;
y[m][0]=r;
y[m][1]=c;
map[r][c]=1;
}
if(g>1&&loop>=2)
{
cout<<endl;
}
cout<<"Case "<<g<<":"<<endl;
for(int j=1; j<=q; j++)
{
find(y[j][0],y[j][1]);
}

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: