您的位置:首页 > 产品设计 > UI/UE

【HDU 2604】 Queuing

2016-04-04 17:22 591 查看
Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.



Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue
else it is a E-queue.

Your task is to calculate the number of E-queues mod M with length L by writing a program.

Input

Input a length L (0 <= L <= 10 6) and M.

Output

Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.

Sample Input

3 8
4 7
4 8


Sample Output

6
2
1


Author

WhereIsHeroFrom

Source

HDU 1st “Vegetable-Birds
Cup” Programming Open Contest

之前有写过相同的题:点击打开链接

唯一的变化就是该题递推个数有10^6

普通的递推将化产生超时的情况

下面引用巨巨解释:

用f(n)表示n个人满足条件的结果,那么如果最后一个人是m的话,那么前n-1个满足条件即可,就是f(n-1);

如果最后一个是f那么这个还无法推出结果,那么往前再考虑一位:那么后三位可能是:mmf, fmf, mff, fff,其中fff和fmf不满足题意所以我们不考虑,但是如果是

mmf的话那么前n-3可以找满足条件的即:f(n-3);如果是mff的话,再往前考虑一位的话只有mmff满足条件即:f(n-4)

所以f(n)=f(n-1)+f(n-3)+f(n-4),递推会跪,可用矩阵快速幂

构造一个矩阵:



#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
typedef long long ll;

const int N = 0;
const int SIZE = 4;

int l, MOD;

struct Mat {
ll v[SIZE][SIZE];	// value of matrix

Mat() {
memset(v, 0, sizeof(v));
}

void init(ll _v) {
rep (i, 0, SIZE)
v[i][i] = _v;
}
};

Mat operator *(Mat a, Mat b) {
Mat c;
rep (i, 0, SIZE - 1)
{
rep (j, 0, SIZE - 1)
{
c.v[i][j] = 0;
rep (k, 0, SIZE - 1)
{
c.v[i][j] += (a.v[i][k] * b.v[k][j]) % MOD;
c.v[i][j] %= MOD;
}
}
}
return c;
}

Mat operator ^(Mat a, ll k) {
Mat c;
c.init(1);
while (k) {
if (k & 1)
c = a * c;
a = a * a;
k >>= 1;
}
return c;
}

int main() {
Mat a, b, c;
// a
a.v[0][0] = 9;
a.v[1][0] = 6;
a.v[2][0] = 4;
a.v[3][0] = 2;

// b
b.v[0][0] = b.v[0][2] = b.v[0][3] = b.v[1][0] = b.v[2][1] = b.v[3][2] = 1;

while (~scanf("%d%d", &l, &MOD)) {
if (l == 0) {
puts("0");
} else if (l <= 4) {
printf("%lld\n", a.v[4 - l][0] % MOD);
} else {
c = b ^ (l - 4);
c = c * a;
printf("%lld\n", c.v[0][0] % MOD);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: