您的位置:首页 > 其它

【Lightoj】 1078-多少个可以整除

2016-03-31 18:04 295 查看
Description

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible
by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit(1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

#include<stdio.h>
int main()
{
int t;
int num=0;
scanf("%d",&t);
while(t--)
{
num+=1;
int a,b;
int c=1;
scanf("%d%d",&a,&b);
int y=b%a;
printf("Case %d: ",num);		//可尝试分步输出
while(y)
{
y=(y*10+b)%a;
c++;
}
printf("%d\n",c);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: