您的位置:首页 > 其它

山东省第一届ACM大学生程序设计竞赛 Phone Number 字典树

2016-03-30 20:54 423 查看

Phone Number


Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

We know that if a phone number A is another phone number B’s prefix, B is not able to be called. For an example, A is 123 while B
is 12345, after pressing 123, we call A, and not able to call B.
Given N phone numbers, your task is to find whether there exits two numbers A and B that A is B’s prefix.

输入

 The input consists of several test cases.
 The first line of input in each test case contains one integerN (0<N<1001), represent the number of phone numbers.
 The next line containsN integers, describing the phone numbers.
 The last case is followed by a line containing one zero.

输出

 For each test case, if there exits a phone number that cannot be called, print “NO”, otherwise print “YES” instead.

示例输入

2
012
012345
2
12
012345
0


示例输出

NO
YES


提示

 

来源

 2010年山东省第一届ACM大学生程序设计竞赛

水题字典树,判断是否有前缀号码出现

ACcode:

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define MAX 10
#define maxn 1005
using namespace std;
struct Trie{
Trie* next[MAX];
int v;
};
struct STR{
char str[maxn];
int len;
bool operator<(const STR &a)const{
return (this->len<a.len);
}
}my[maxn];
Trie *root;
int n,ans,num;
void createTire(char *str){
int len=strlen(str);
Trie *p=root,*q;
for(int i=0;i<len;++i){
int id=str[i]-'0';
if(p->next[id]==NULL){
q=(Trie *)malloc(sizeof(Trie));
q->v=1;
for(int j=0;j<MAX;++j)
q->next[j]=NULL;
p->next[id]=q;
p=p->next[id];
}
else{
p->next[id]->v++;
p=p->next[id];
}
}
p->v=-1;
}
int findTrie(char *str){
int len=strlen(str);
Trie *p=root;
for(int i=0;i<len;++i){
int id=str[i]-'0';
p=p->next[id];
if(p==NULL)
return 0;
if(p->v==-1)
return 0;
}
return 2;
}
void init(){
root=(Trie *)malloc(sizeof(Trie));
for(int i=0;i<MAX;++i)
root->next[i]=NULL;
ans=num=0;
memset(my,0,sizeof(my));
}
int main(){
while(~scanf("%d",&n)&&n){
init();
for(int i=0;i<n;++i){
scanf("%s",my[i].str);
my[i].len=strlen(my[i].str);
}
sort(my,my+n);
for(int i=0;i<n;++i)createTire(my[i].str);
// for(int i=0;i<n;i++)cout<<my[i].str<<'\12';
for(int i=0;i<n;++i)
ans+=findTrie(my[i].str);
//cout<<"ans: "<<ans<<'\12';
for(int i=0;i<n&&!ans;++i)
for(int j=i+1;j<n;++j)
if(!strcmp(my[i].str,my[j].str))
ans++;
printf(ans>0?"NO\n":"YES\n");
}
return 0;
}
/*
2 012 012345 2 12 012345 0
*/

暴力做法

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <vector>
#define maxn 1005
#define inf 0x7fffffffff
#define ll long long
using namespace std;
int n,m,loop;
struct N {
char s[maxn];
int len;
}my[maxn];
bool cmp(N a,N b){return a.len<b.len;}
int len[maxn];
int main(){
while(scanf("%d",&n)&&n){
for(int i=1;i<=n;++i){
scanf("%s",my[i].s);
my[i].len=strlen(my[i].s);
}
sort(my+1,my+1+n,cmp);
bool flag=true;
for(int i=1;flag&&i<=n;++i)
for(int j=i+1;flag&&j<=n;++j){
int ok=0;
for(int z=0;z<my[i].len;++z)
if(my[i].s[z]==my[j].s[z])ok++;
if(ok==my[i].len)flag=false;
}
if(flag)puts("YES");
else puts("NO");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: