您的位置:首页 > 其它

UVALIVE 4329(树状数组)

2016-03-30 20:48 459 查看
https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2330

N (3 ≤ N ≤ 20000) ping pong players live along a west-east street(consider the street as a line segment).

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If

two players want to compete, they must choose a referee among other ping pong players and hold the

game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is

higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because

they are lazy, they want to make their total walking distance no more than the distance between their

houses. Of course all players live in different houses and the position of their houses are all different. If

the referee or any of the two contestants is different, we call two games different. Now is the problem:

how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T (1 ≤ T ≤ 20), indicating the number of test cases,

followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N

distinct integers a1, a2 . . . aN follow, indicating the skill rank of each player, in the order of west to east

(1 ≤ ai ≤ 100000, i = 1. . . N).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1

3 1 2 3

Sample Output

1

人生树状数组的第一发。。。

虽然这道题目上在算法竞赛的蓝皮上有题解,但是没有代码,打起来还是好吃力,表示代码能力太差了,有时候给我题解也解不出来。看来应该要好好的锻炼一下了。然后具体的解法就看蓝皮书的197页吧,很详细。

#include<bits stdc="" h="">

using namespace std;

typedef long long ll;
const int maxn = 200000 + 5;
const int maxa = 100000 + 5;
int a[maxn];
int n;
int x[maxa];
int c[maxn], d[maxn];

void init(){
memset(d, 0, sizeof(d));
memset(c, 0, sizeof(c));
memset(a, 0, sizeof(a));
memset(x, 0, sizeof(x));
for (int i = 1; i <= n; i++){
scanf("%d", a + i);
}
}

int lowbit(int x){
return x & (-x);
}

void add(int y, int d){
while (y <= 100000){
x[y] += d;
y += lowbit(y);
}
}

ll sum(int y){
ll res = 0;
while (y > 0){
res += x[y];
y -= lowbit(y);
}
return res;
}

void solve(){
for (int i = 1; i <= n; i++){
add(a[i] , 1);
c[i] = sum(a[i] - 1);
}
memset(x, 0, sizeof(x));
for (int i = n; i >= 1; i--){
add(a[i], 1);
d[i] = sum(a[i] - 1);
}
ll res = 0;
for (int i = 1; i <= n; i++){
res += c[i] * (n - i - d[i]) + (i - c[i] - 1) * d[i];
}
printf("%lld\n", res);
}

int main(){
int t;
scanf("%d", &t);
while (t--){
scanf("%d", &n);
init();
solve();
}
return 0;
}

</bits>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: