您的位置:首页 > 其它

POJ 3122 Pie (二分查找)

2016-03-30 17:03 288 查看
Pie

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14107 Accepted: 4837 Special Judge
Description


My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are
coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input

One line with a positive integer: the number of test cases. Then for each test case:
One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output
25.1327
3.1416
50.2655

Source
Northwestern Europe 2006
二分法查找,类似于猜数字游戏,不断地进行折半缩小范围
题意:生日家里来了F个朋友,他家里有好N个Pie,主人希望把Pie分出F+1份(自己也要一个),要求体积相同,所有的Pie不需要都分完,问你每个人最大能分到多大体积的Pie。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define PI 3.14159265359
using namespace std;
double pi[110000];
int n,m;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
double maxx=0;
for(int i=0;i<n;i++)
{
scanf("%lf",&pi[i]);//pie的半径
pi[i]*=pi[i];
maxx=max(maxx,pi[i]);//取最大的pie
}
m=m+1;
double l=0;
double r=maxx;
double mid;
while(r-l>0.000001)
{
mid=(r+l)/2;
int sum=0;
for(int i=0;i<n;i++)
{
if((pi[i]-mid)>0.000001)
{
sum+=(int)pi[i]/mid;
}
}
if(sum>=m)
{
l=mid;
}
else
{
r=mid;
}
}
printf("%.4lf\n",PI*mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: