您的位置:首页 > 产品设计 > UI/UE

【Poj 2533】 Longest Ordered Subsequence 最长上升子序列

2016-03-30 14:28 381 查看
Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 43410 Accepted: 19139

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7

1 7 3 5 9 4 8

Sample Output

4

题目链接http://poj.org/problem?id=2533

题意:

Longest Ordered Subsequence

思路:Longest Ordered Subsequence

代码

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int n;
int dp[1005];
int a[1005];

int maxx;
int main()
{
scanf("%d",&n);

for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
dp[i]=1;
}

maxx=0;

for(int i=1;i<=n;i++)
for(int j=1;j<i;j++)
if(a[i]>a[j])
{
dp[i]=max(dp[i],dp[j]+1);
}
for(int i=1;i<=n;i++)
maxx=max(maxx,dp[i]);
printf("%d\n",maxx);

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: