您的位置:首页 > 其它

POJ 2396 Lake Counting(简单dfs)

2016-03-29 15:25 531 查看
Lake Counting

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 26942Accepted: 13532
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.').
Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3


这个题目是简单的深度搜索题目,题意:连天下雨,农夫的n*m田地里有积水,积水连成了小水洼,让你计算小水洼有几个。

易知,这个题目的做法是dfs,因为其“从某一个状态转移到另一个状态,直到其无法转移为止,且无固定初末状态”。

代码如下:

#include<iostream>
using namespace std;
int n,m;
char str[105][105];
void solve();
void dfs(int ,int );
int main()
{
cin>>n>>m;//n行m列
for(int i=0;i<n;i++)
cin>>str[i];
solve();
return 0;
}
void solve()
{
int res=0;
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
if(str[i][j]=='W')
{
dfs(i,j);
res++;
}
cout<<res<<endl;
}
void dfs(int x,int y)
{
int nx,ny;
str[x][y]='.';//走过的水坑更新为陆地
//遍历上下左右八个方向
for(int fx=-1;fx<=1;fx++)
for(int fy=-1;fy<=1;fy++)
{
nx=x+fx,ny=y+fy;
//判断遍历的点是否在n*m的地盘内以及是否是水坑
if(nx>=0&&nx<n&&ny>=0&&ny<m&&str[nx][ny]=='W')
dfs(nx,ny);
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: