您的位置:首页 > 产品设计 > UI/UE

hdoj 1242Rescue

2016-03-29 11:17 411 查看
D - BFS

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8

#.#####.

#.a#..r.

#..#x...

..#..#.#

#...##..

.#......

........

Sample Output

13

测试数据中除了有‘#’'a' 'r' '.' 之外还有其他的字符

代码:

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int n,m,s,t;
int xx[4]={0,0,1,-1};
int yy[4]={1,-1,0,0};
char map[220][220];
bool fafe[220][220];
struct node{
int x,y;
int bushu;
friend bool operator < (node xx,node yy)
{
return xx.bushu>yy.bushu;
}
};
void dfs(int ss,int tt)
{
priority_queue<node> que;
node now,qian;
int nn,mm,ppp=0;
memset(fafe,false,sizeof(fafe));
now.x=ss;now.y=tt;now.bushu=0;
que.push(now);
fafe[ss][tt]=true;
while (!que.empty())
{
qian=que.top();
que.pop();
for (int i=0;i<4;i++)
{
nn=qian.x+xx[i];
mm=qian.y+yy[i];
now.x=nn;now.y=mm;
if (fafe[nn][mm]||nn<0||mm<0||nn==n||mm==m||map[nn][mm]=='#')
continue;
{if (map[nn][mm]=='.')
now.bushu=qian.bushu+1;
else if (map[nn][mm]=='x')
now.bushu=qian.bushu+2;
else if (map[nn][mm]=='r')
{
ppp=qian.bushu+1;
break;
}
fafe[nn][mm]=true;
que.push(now);}
}
if (ppp)
break;
}
if (ppp)
printf("%d\n",ppp);
else
printf("Poor ANGEL has to stay in the prison all his life.\n");
}
int main()
{
while (~scanf("%d%d",&n,&m))
{
getchar();
for (int i=0;i<n;i++)
{
scanf("%s",map[i]);
for (int j=0;j<m;j++)
if (map[i][j]=='a')
s=i,t=j;
}
dfs(s,t);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: