您的位置:首页 > 其它

ZOJ 3469Food Delivery(区间DP)

2016-03-29 08:51 260 查看
Food Delivery

Time Limit: 2 Seconds Memory Limit: 65536 KB

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.
Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters.
And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food
to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.
You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure
Index
. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ithperson will gain Bi Displeasure Index per minute.
If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Indexas
low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.
Input
The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0),X ( X >=
0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.
You can safely assume that all numbers in the input and output will be less than 231 - 1.
Please process to the end-of-file.
Output
For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.
Sample Input
5 1 0

1 1

2 2

3 3

4 4

5 5

Sample Output
55

区间DP
dp[i][j][k] 表示i到j这个区间送完了,快递小哥在哪个端点。
关于区间DP,可以参照这个博客

http://blog.csdn.net/dacc123/article/details/50885903
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
#define MAX 100000000
int n,v,x;
struct Node
{
int xi;
int bi;
}a[1005];
int dp[1005][1005][2];
int cmp(Node a,Node b)
{
return a.xi<b.xi;
}
int sum[1005];
int main()
{
while(scanf("%d%d%d",&n,&v,&x)!=EOF)
{
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a[i].xi,&a[i].bi);
}
a[n+1].xi=x;a[n+1].bi=0;
sort(a+1,a+n+2,cmp);
int pos=0;
sum[0]=0;
for(int i=1;i<=n+1;i++)
sum[i]=sum[i-1]+a[i].bi;
for(int j=1;j<=n+1;j++)
if(a[j].xi==x)
pos=j;
for(int i=0;i<=n+1;i++)
for(int j=0;j<=n+1;j++)
dp[i][j][0]=MAX,dp[i][j][1]=MAX;
dp[pos][pos][0]=0;
dp[pos][pos][1]=0;
for(int i=pos;i>=1;i--)
{
for(int j=pos;j<=n+1;j++)
{
if(i==j)
continue;
int num=sum[i-1]-sum[0]+sum[n+1]-sum[j];
dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(a[j].xi-a[j-1].xi)*(a[j].bi+num));
dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(a[j].xi-a[i].xi)*(a[j].bi+num));
dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(a[i+1].xi-a[i].xi)*(a[i].bi+num));
dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(a[j].xi-a[i].xi)*(a[i].bi+num));
}
}
printf("%d\n",min(dp[1][n+1][0],dp[1][n+1][1])*v);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: