您的位置:首页 > 其它

POJ 1442 (treap)

2016-03-28 17:20 239 查看
Black Box

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9871 Accepted: 4043
Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer

(elements are arranged by non-descending)

1 ADD(3)      0 3

2 GET         1 3                                    3

3 ADD(1)      1 1, 3

4 GET         2 1, 3                                 3

5 ADD(-4)     2 -4, 1, 3

6 ADD(2)      2 -4, 1, 2, 3

7 ADD(8)      2 -4, 1, 2, 3, 8

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8

9 GET         3 -1000, -4, 1, 2, 3, 8                1

10 GET        4 -1000, -4, 1, 2, 3, 8                2

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 

Let us describe the sequence of transactions by two integer arrays: 

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 

Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output
3
3
1
2

Source

Northeastern Europe 1996

题意:题意还是太长了,其实还是很好懂的题意,简单的说就是问你,动态查询有x个数字的数组,他第i大的数字是多少?这

题解:这里我们很容易想到使用set,map之类的,但是我想了一下,好像set不能直接查询第k大的数字呀!只能一次一的遍历呀,于是查了资料确实是不能查询,好吧查了下题解,看到2种做法,一是使用2个优先队列维护第k大的关系,第二个正是我要说的treap,treap封装了类似set,map的排序二叉树的方式维护数字的大小,除此之外,他还可以快速查找第k大的元素,查询数字x的名次,真是太方便啦!那么这一题就是treap的模板题了,这里我们的kth函数有2种查询方式,较小优先和较大优先。和set的greater和less是不是很像?

#include <cstdio>
#include<iostream>
#include <cstdlib>
#include<cstring>
#include<ctime>
using namespace std;
struct Node
{
Node *ch[2];
int r;
int v;
int s;
Node() {}
Node(int v) : v(v) {
ch[0] = ch[1] = NULL; r = rand(); s = 1;
}
bool operator < (const Node& rhs) const {
return r < rhs.r;
}
int cmp(int x) const {
if (x == v) return -1;
return x < v ? 0 : 1;
}
void maintain() {
s = 1;
if (ch[0] != NULL) s += ch[0]->s;
if (ch[1] != NULL) s += ch[1]->s;
}
};

void rotate(Node* &o, int d) {
Node* k = o->ch[d ^ 1]; o->ch[d ^ 1] = k->ch[d]; k->ch[d] = o;
o->maintain(); k->maintain(); o = k;
}

void insert(Node* &o, int x) {
if (o == NULL) {
o = new Node(x);
}
else {
int d = (x < o->v ? 0 : 1);
insert(o->ch[d], x);
if ((o->ch[d]->r) >(o->r)) rotate(o, d ^ 1);
}
o->maintain();
}

void remove(Node* &o, int x) {
int d = o->cmp(x);
if (d == -1) {
Node* u = o;
if (o->ch[0] != NULL && o->ch[1] != NULL) {
int d2 = (o->ch[0] > o->ch[1] ? 1 : 0);
rotate(o, d2); remove(o->ch[d2], x);
}
else {
if (o->ch[0] == NULL) o = o->ch[1];
else o = o->ch[0];
delete u;
}
}
else
remove(o->ch[d], x);
if (o != NULL) o->maintain();
}

int kth_small(Node* o, int k) //数字小优先
{
if (o == NULL || k <= 0 || k > o->s)
return 0;
int s = (o->ch[0] == NULL ? 0 : o->ch[0]->s);
if (k == s + 1) return o->v;
else if (k <= s) return kth_small(o->ch[0], k);
else return kth_small(o->ch[1], k - s - 1);
}

int kth_big(Node *o, int k)//数字大优先
{
if (o == NULL || k <= 0 || k > o->s)
return 0;
int s = o->ch[1] == NULL ? 0 : o->ch[1]->s;
if (s + 1 == k)
return o->v;
else {
if (s >= k)
return kth_big(o->ch[1], k);
else
return kth_big(o->ch[0], k - s - 1);
}
}

void remove_tree(Node *&o) {
if (o->ch[0] != NULL)
remove_tree(o->ch[0]);
if (o->ch[1] != NULL)
remove_tree(o->ch[1]);
delete o;
o = NULL;
}
int n, m, a[30010];
Node *rt = NULL;
int main()
{
#ifdef CDZSC
freopen("i.txt", "r", stdin);
#endif
while (scanf("%d %d", &n, &m) != EOF)
{
srand(time(0));
for (int i = 1; i <= n; i++)
scanf("%d", &a[i]);
int l = 1;
for (int i = 1; i <= m; i++)
{
int x;
scanf("%d", &x);
while (l <= x)
{
insert(rt, a[l]);
l++;
}
//for (int j = 1;j<=i;j++)
printf("%d\n", kth_small(rt, i));
//printf(" %d\n", kth_big(rt, i));
}
remove_tree(rt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: