您的位置:首页 > 其它

POJ 1979 红与黑 优先深度搜索

2016-03-27 22:31 176 查看

题目连接

http://poj.org/problem?id=1979

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile

‘#’ - a red tile

‘@’ - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9

….#.

…..#

……

……

……

……

……

#@…#

.#..#.

11 9

.#………

.#.#######.

.#.#…..#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#…….#.

.#########.

………..

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

…@…

###.###

..#.#..

..#.#..

0 0

Sample Output

45

59

6

13

Hint

题意

一次性相连的‘ . ’有多少个

题解

其实和水洼那题差不多,区别是数据简单处理一下,还有就是这次只能上下左右搜索而不是周围八个格子都搜索

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<string>
#include<cctype>
#include<algorithm>
#include<vector>
#define INF  1e9+7
int n,m,ans;
int dx[4]={-1,0,1,0};
int dy[4]={0,1,0,-1};
using namespace std;
char a[110][110];
void dfs(int q,int p){
a[q][p]='#';
for (int i = 0; i <4 ; ++i)
{

int nx=q+dx[i];
int ny=p+dy[i];
if (a[nx][ny]=='.'&&nx>=0&&nx<m&&ny>=0&&ny<n)
{
//a[q+i][p+j]='.';
ans++;
dfs(nx,ny);
}

}
}
int main(int argc, char const *argv[])
{
ans=1;
fflush(stdin);   //清空输入流  上一个scanf预留的\n
while(scanf("%d%d",&n,&m)!=EOF){
memset(a,0,sizeof(a));
ans=1;
if (n==0&&m==0)
{
return 0;
}
int z,g;
for (int i = 0; i < m; ++i)
{
for (int j = 0; j < n; ++j)
{
cin>>a[i][j];
if(a[i][j]=='@'){

z=i;
g=j;}
// scanf("%c",&a[i][j]);
}
}
dfs(z,g);
printf("%d\n",ans );
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: