您的位置:首页 > 其它

poj-3096-Surprising Strings

2016-03-27 22:25 429 查看
Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is
D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG
is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of
Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*


Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.


定义D-pairs表示取字符串s中相距为D的两个字母所构成的字母对,该字母对中两个字母的位置顺序与他们在主串s中的位置顺序一致

定义D-unique表示,若从字符串s中取出所有相距为D的字母对D-pairs,且这些D-pairs都是独一无二的,那么成字符串s是一个D-unique串

假如字符串s对于所有的D都有D-unique成立,则字符串s是令人惊讶的
= =

现在输入一些字符串,问他们能不能surprising

水题吧,我用了一个三维数组,前两维记录下第一个字母和第二个字母,第三维记录距离,然后发现距离大于1就Not了

但是我WAl两发,我特么sabi的统计的时候统计的字符串长度而没有统计26个字母,哎,我是个辣鸡

但这道题我是水过去的因为数据小啊,才76,用map更好

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

char s[100];
int d[30][30][100];

int main()
{
while(scanf("%s",s)!=EOF)
{
int a=0,b=0,val=0;
for(int i=0;i<30;i++)
for(int j=0;j<30;j++)
for(int k=0;k<100;k++)
d[i][j][k]=0;
bool flag=true;
if(strcmp(s,"*")==0) break;
int l=strlen(s);
//printf("%s\n",s);
if(l<=2)
{
cout<<s<<" is surprising."<<endl;
continue;
}
else
{
for(int i=0;i<l;i++)
for(int j=i+1;j<l;j++)
{
a=s[i]-'A';
b=s[j]-'A';
val=j-i-1;
d[a][b][val]++;
//printf("%d %d %d\n",a,b,val);
}
for(int i=0;i<30;i++)
for(int j=0;j<30;j++)
for(int k=0;k<100;k++)
{
if( d[i][j][k]>1 )
{
flag=false; //printf("i=%d j=%d k=%d %d\n",i,j,k,d[i][j][k]); }
}
}
if(flag) cout<<s<<" is surprising."<<endl;
else cout<<s<<" is NOT surprising."<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: