您的位置:首页 > 运维架构

PAT (Advanced Level) Practise 1114 Family Property (25)

2016-03-26 21:48 399 查看


1114. Family Property (25)

时间限制

150 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real
estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5)
is the number of children of this person; Childi's are the ID's of his/her children;M_estate is the total number of sets of the real estate under his/her name; and Area is
the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average
numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.
Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

其实就是找连通块,直接存下关系dfs即可。
#include<map>
#include<cstdio>
#include<vector>
#include<cmath>
#include<queue>
#include<string>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int low(int x){ return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
int T, id, C, U, V, tot;
int x, u[maxn], v[maxn], y, z, f[maxn];
vector<int> t[maxn];

struct point
{
int a, b;
double c, d;
point(int a = 0, int b = 0, double c = 0, double d = 0) :a(a), b(b), c(c), d(d){}
bool operator<(const point &f)const
{
return d == f.d ? a<f.a : d>f.d;
}
}p[maxn];

void dfs(int x)
{
id = min(x, id);	C++;
U += u[x];	V += v[x]; f[x] = 0;
for (int i = 0; i < t[x].size(); i++)
{
if (f[t[x][i]]) dfs(t[x][i]);
}
}

int main()
{
scanf("%d", &T);
while (T--)
{
scanf("%d%d%d", &x, &y, &z);
f[x] = 1;
if (y != -1) { t[x].push_back(y); t[y].push_back(x); f[y] = 1; }
if (z != -1) { t[x].push_back(z); t[z].push_back(x); f[z] = 1; }
scanf("%d", &y);
while (y--)
{
scanf("%d", &z);	f[z] = 1;
t[x].push_back(z); t[z].push_back(x);
}
scanf("%d%d", &u[x], &v[x]);
}
for (int i = 0; i < 10000; i++)
{
if (!f[i]) continue;
C = 0;	id = 10000;	U = 0;	V = 0;
dfs(i);
p[tot++] = point(id, C, 1.0*U / C, 1.0*V / C);
}
sort(p, p + tot);
printf("%d\n", tot);
for (int i = 0; i < tot; i++)
{
printf("%04d %d %.3lf %.3lf\n", p[i].a, p[i].b, p[i].c, p[i].d);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT