您的位置:首页 > 其它

HDU1520 Anniversary party(树形dp)

2016-03-26 15:48 405 查看

Anniversary party

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8046    Accepted Submission(s): 3507
[/b]

[align=left]Problem Description[/align]
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E.
Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached
to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

 

[align=left]Input[/align]
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number
in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0
 

[align=left]Output[/align]
Output should contain the maximal sum of guests' ratings.

 

[align=left]Sample Input[/align]

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

 

[align=left]Sample Output[/align]

5

 

[align=left]Source[/align]
Ural State University Internal Contest
October'2000 Students Session

题意:举办一个派对,想邀请校内职员参加,但是不同时邀请员工的该员工的直属上级,每位职员都有一个评级,问怎样邀请能使评级之和最大?
思路:刚开始用dp[i][j][0 or 1]表示第i个职员包括他的下属一共邀请j个能获得的最大值,dp[i][j][0]表示第i个不邀请,dp[i][j][1]表示邀请第i个。后来内存超了。
现在想来为什么一定要限制人数......所以应该用dp[i][0 or 1]这样就可以了,dp[fa][0] += max(dp[son][0], dp[son][1]), dp[fa][1] += dp[son][0]。这样就是普通的树形dp了。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxn 6005
int dp[maxn][2], val[maxn], head[maxn], tot, N;
bool vis[maxn];
struct Edge{
int to, next;
}edge[maxn*2];
void add(int u, int v){
edge[tot].to = v;
edge[tot].next = head[u];
head[u] = tot++;
}
void dfs(int fa){
int i, j, k, son;
vis[fa] = 1;
dp[fa][1] = val[fa];
for(i = head[fa];i != -1;i = edge[i].next){
son = edge[i].to;
//printf("fa:%d   son:%d\n", fa, son);
if(vis[son]) continue;
dfs(son);
dp[fa][0] += max(dp[son][0], dp[son][1]);
dp[fa][1] += dp[son][0];
}
}
int main()
{
int i, u, v, rt;
while(scanf("%d", &N) != EOF){
tot = 1;
memset(head, -1, sizeof head);
memset(vis, 0, sizeof vis);
memset(dp, 0, sizeof dp);
for(i = 1;i <= N;i++) scanf("%d", &val[i]);
while(scanf("%d %d", &v, &u)){
if(!u&&!v) break;
add(u, v);
vis[v] = true;
}
for(i = 1;i <= N;i++){
if(!vis[i]) rt = i;
vis[i] = false;
}
//printf("%d\n", rt);
dfs(rt);
printf("%d\n", max(dp[rt][0], dp[rt][1]));
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu dp 树形dp