您的位置:首页 > 其它

1002 of greedy strategy

2016-03-25 13:23 176 查看
Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

 

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers
on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

 

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

 

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

 

Sample Output

200
0
0

 题目要求:田忌赛马喽,合理的分配马的比赛顺序,怎样使赢的钱最多。

思路:1要让马发挥最大的效益,先从两组最慢的马进行比较,若能赢则赢,若输则输。但如果是平的话,就要考虑最快的一组马,若能赢则赢,否则就让田忌最慢的马去比掉另一方最快的马。最后便达到最大的马的利用率。

细节:思路对了代码对了不出意外的话应该没什么问题。

感想:做题一是思路,二是细节,二者缺一不可。开始时思路错误把平局考虑简单了直接和另组最快的马比导致wa。好在模拟了30组数据和正确代码比较才发现错误。

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
int greedy(int a[], int b[], int n)
{
    int tmax=n-1,tmin=0,qmax=n-1,qmin=0 ,count = 0, count1 = 0;
    int c[1100];memset(c, 0, sizeof(c));
    while(tmax>=tmin)
    {
        if(a[tmin]>b[qmin]){count++;tmin++;qmin++;}
        else if(a[tmin]<b[qmin]){tmin++;qmax--;count1++;}
        else {if(a[tmax]>b[qmax]){count++;tmax--;qmax--;}
        else{if(a[tmin]<b[qmax])count1++;tmin++;qmax--;
        }}
    }
    return (-200 * count1 + 200 * count);
}
int main()
{
    int a[1100], b[1100], n;
    while (scanf("%d", &n) == 1 && n)
    {
        for (int i = 0;i < n;i++)
            scanf("%d", &a[i]);
        for (int i = 0;i < n;i++)
            scanf("%d", &b[i]);
        sort(a, a + n);
        sort(b, b + n);
        printf("%d\n", greedy(a, b, n));
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: