您的位置:首页 > 其它

1003,字母编码最短

2016-03-25 12:07 246 查看
问题描述:An entropy encoder is a data encoding method that achieves lossless data compression by encoding a message with “wasted” or “extra” information removed. In other words, entropy encoding removes information that was not necessary in the first place to accurately encode the message. A high degree of entropy implies a message with a great deal of wasted information; english text encoded in ASCII is an example of a message type that has very high entropy. Already compressed messages, such as JPEG graphics or ZIP archives, have very little entropy and do not benefit from further attempts at entropy encoding.

English text encoded in ASCII has a high degree of entropy because all characters are encoded using the same number of bits, eight. It is a known fact that the letters E, L, N, R, S and T occur at a considerably higher frequency than do most other letters in english text. If a way could be found to encode just these letters with four bits, then the new encoding would be smaller, would contain all the original information, and would have less entropy. ASCII uses a fixed number of bits for a reason, however: it’s easy, since one is always dealing with a fixed number of bits to represent each possible glyph or character. How would an encoding scheme that used four bits for the above letters be able to distinguish between the four-bit codes and eight-bit codes? This seemingly difficult problem is solved using what is known as a “prefix-free variable-length” encoding.

In such an encoding, any number of bits can be used to represent any glyph, and glyphs not present in the message are simply not encoded. However, in order to be able to recover the information, no bit pattern that encodes a glyph is allowed to be the prefix of any other encoding bit pattern. This allows the encoded bitstream to be read bit by bit, and whenever a set of bits is encountered that represents a glyph, that glyph can be decoded. If the prefix-free constraint was not enforced, then such a decoding would be impossible.

Consider the text “AAAAABCD”. Using ASCII, encoding this would require 64 bits. If, instead, we encode “A” with the bit pattern “00”, “B” with “01”, “C” with “10”, and “D” with “11” then we can encode this text in only 16 bits; the resulting bit pattern would be “0000000000011011”. This is still a fixed-length encoding, however; we’re using two bits per glyph instead of eight. Since the glyph “A” occurs with greater frequency, could we do better by encoding it with fewer bits? In fact we can, but in order to maintain a prefix-free encoding, some of the other bit patterns will become longer than two bits. An optimal encoding is to encode “A” with “0”, “B” with “10”, “C” with “110”, and “D” with “111”. (This is clearly not the only optimal encoding, as it is obvious that the encodings for B, C and D could be interchanged freely for any given encoding without increasing the size of the final encoded message.) Using this encoding, the message encodes in only 13 bits to “0000010110111”, a compression ratio of 4.9 to 1 (that is, each bit in the final encoded message represents as much information as did 4.9 bits in the original encoding). Read through this bit pattern from left to right and you’ll see that the prefix-free encoding makes it simple to decode this into the original text even though the codes have varying bit lengths.

As a second example, consider the text “THE CAT IN THE HAT”. In this text, the letter “T” and the space character both occur with the highest frequency, so they will clearly have the shortest encoding bit patterns in an optimal encoding. The letters “C”, “I’ and “N” only occur once, however, so they will have the longest codes.

There are many possible sets of prefix-free variable-length bit patterns that would yield the optimal encoding, that is, that would allow the text to be encoded in the fewest number of bits. One such optimal encoding is to encode spaces with “00”, “A” with “100”, “C” with “1110”, “E” with “1111”, “H” with “110”, “I” with “1010”, “N” with “1011” and “T” with “01”. The optimal encoding therefore requires only 51 bits compared to the 144 that would be necessary to encode the message with 8-bit ASCII encoding, a compression ratio of 2.8 to 1.

Input
The input file will contain a list of text strings, one per line. The text strings will consist only of uppercase alphanumeric characters and underscores (which are used in place of spaces). The end of the input will be signalled by a line containing only the word “END” as the text string. This line should not be processed.

Output
For each text string in the input, output the length in bits of the 8-bit ASCII encoding, the length in bits of an optimal prefix-free variable-length encoding, and the compression ratio accurate to one decimal point.

[align=left]Sample Input[/align]

  AAAAABCD

  THE_CAT_IN_THE_HAT
END

[align=left]Sample Output[/align]

  64 13 4.9

  144 51 2.8

意思:给你一段字符转,让你对字符串进行编码,输出编码的平均最短长度

思路:可以先将字符串中的字符出现次数进行计算,然后将这些次数进行最优树产生最有编码,然后求出最短字符编码长度
代码:

#include <iostream>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;
int INF=0x3f3f3f3f;//无穷大

typedef struct Node
{
  int data;//结点值
  int parent;//记录其父节点
}node;
node nd[100];//建立100个结点

//哈弗曼树的产生
void hufman(int n)
{
  int m1,m2,x1,x2,pa;//m1,m2记录数据中最小的两个数,用于构建结点
  for(int i = 0;i < n;i++)
  {
    m1 = m2 = INF;
    for(int j = 0;j < n+i;j++)
    {
      if(m1 > nd[j].data&&nd[j].parent==-1&&nd[j].data!=0)//如果结点比m1小,且值不为零,没有使用过就执行下面操作
      {
        m2 = m1;//m1 < m2如果m1有更小的,则将m1赋给m2
        m1 = nd[j].data;
        x2 = x1;
        x1 = j;
      }
      else if(m2 > nd[j].data&&nd[j].parent==-1&&nd[j].data!=0)
      {
        m2 = nd[j].data;
        x2 = j;
      }
    }
    if(m2 != INF)
    {
      pa = n + i;
      nd[pa].data = m1+m2;//其两个最小值的和构成其父节点
      nd[x1].parent = nd[x2].parent = pa;//删除两个结点
    }
  }
}

int main()
{
  int i,l,c,p,ans;
  char s[1000];
  while(cin>>s)
  {
    if(strcmp(s,"END")==0)//结束标志
    break;
    for(i=0;i<80;i++)//初始化
    {
      nd[i].data=0;
      nd[i].parent=-1;
    }
    l=strlen(s);//记录字符串长度
    for(i=0;i<l;i++)
    if(s[i]=='_')
      nd[26].data++;//建立字符与数字下标的映射
    else
      nd[s[i]-'A'].data++;
    hufman(27);//建立哈弗曼树
    for(i=0;i<=26;i++)
    {
      c=0;//c记录编码所需长度,通过计算节点父节点的个数,就可以知道节点的编码长度
      if(nd[i].data!=0)
      {
        p=i;
        while(nd[p].parent!=-1)
        {
          c++;
          p=nd[p].parent;
        }
        if(c==0)//如果为根节点长度为1
          c=1;
        nd[i].data=c;//将data赋值为所需字节数。方便下面算总数
      }
    }
    ans=0;//ans记录所需总字节数
    for(i=0;i<l;i++)
    {
      if(s[i]=='_')
        ans+=nd[26].data;
      else
        ans+=nd[s[i]-'A'].data;
    }
    printf("%d %d %.1f\n",8*l,ans,8.0*l*1.0/ans);//简化代码
  }
  return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: