您的位置:首页 > 其它

贪心1002

2016-03-22 19:51 232 查看
原题:

[align=left]Problem Description[/align]
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden
sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one
or more spaces.
 

[align=left]Output[/align]
The output should contain the minimum setup time in minutes, one per line.
 

[align=left]Sample Input[/align]

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

 

[align=left]Sample Output[/align]

2
1
3

 
题意是:将木棍放在机器里处理,第一根需要一分钟,剩余的如果大于等于前边放入的长度和重量,就不用费时间,否则需要一分钟,计算给出一组数的最少时间!用贪心算出最少降序序列个数!

代码:#include<stdio.h>

#include<stdlib.h>//此头文件中包含 qsorf

typedef struct stu{//定义指针数组 

int l,w;

}Lode;

Lode s[5005];

int cmp(const void *a,const void *b)//对数组进行排序 

{

Lode *c=(Lode*)a;//强制类型转换 

Lode *d=(Lode*)b;

if(c->l!=d->l)//先排l 

return d->l-c->l;//若为正数排在后面 

else return d->w-c->w;//l相同再排w 小的在前 

}

int main()

{

int t,n,i,j,ans;

scanf("%d",&t);

while(t--)

{

scanf("%d",&n);

for(i=0;i<n;i++)

scanf("%d%d",&s[i].l,&s[i].w);

qsort(s,n,sizeof(s[0]),cmp);//排序s参与排序的数组名,n参与排序的个数 sizeof(s[0])单个元素大小 

ans=n;//下面的就好理解了 

for(i=0;i<n;i++)

for(j=0;j<=i-1;j++)

{

if(s[j].l>=s[i].l&&s[j].w>=s[i].w)

{

ans--;

s[j].l=s[i].l;

s[j].w=s[i].w;

s[i].l=0;

s[i].w=0;

break;

}

}

printf("%d\n",ans);

}

return 0;
}

感想;这个题对现在的我来说还是比较难的,但是学会了qsort的使用
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: