您的位置:首页 > 其它

A - A

2016-03-22 14:54 405 查看
A - A

Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

For hundreds of years Fermat's Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.)
It is possible, however, to find integers greater than 1 that satisfy the "perfect cube" equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program
to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.

Input

One integer N (N <= 100).

Output

The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist
several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.

Sample Input

24

Sample Output

Cube = 6, Triple = (3,4,5)

Cube = 12, Triple = (6,8,10)

Cube = 18, Triple = (2,12,16)

Cube = 18, Triple = (9,12,15)

Cube = 19, Triple = (3,10,18)

Cube = 20, Triple = (7,14,17)

Cube = 24, Triple = (12,16,20)

水,,,,,

代码:

#include<cstdio>
#include<cstring>
struct node{
int sh;
int a[10],b[10],c[10];
}shu[102];
int p[102];
bool fafe(int ii)
{
bool ka=false;
for (int i=2;i<ii-2;i++)
for (int j=i+1;j<ii-1;j++)
for (int s=j+1;s<ii;s++)
if ((p[i]+p[j]+p[s])==p[ii])
{
ka=true;
shu[ii].a[shu[ii].sh]=i;shu[ii].b[shu[ii].sh]=j;shu[ii].c[shu[ii].sh]=s;
shu[ii].sh++;
}
return ka;
}
int main()
{
int t;
scanf("%d",&t);
for (int i=1;i<=t;i++)
p[i]=i*i*i;
memset(shu,0,sizeof(shu));
for (int i=1;i<=t;i++)
{
if (fafe(i))
{
for (int j=0;j<shu[i].sh;j++)
{
// printf("1213341\n");
printf("Cube = %d, Triple = (%d,%d,%d)\n",i,shu[i].a[j],shu[i].b[j],shu[i].c[j]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: