您的位置:首页 > 产品设计 > UI/UE

hdu1159 Common Subsequence--DP

2016-03-21 10:58 489 查看
原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1159
一:原题链接

[align=left]Problem Description[/align]
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.

 
[align=left]Sample Input[/align]

abcfbc abfcab
programming contest
abcd mnp

 
[align=left]Sample Output[/align]

4
2
0

二:分析理解

给出两个字符串,求两个字符串的最长公共字串。



可以看出:

F[i][j]=F[i-1][j-1]+1;(a[i]==b[j])

F[i][j]=max(F[i-1][j],F[i][j-1]);(a[i]!=b[j])

三:AC代码

#include<iostream>
#include<string.h>
#include<algorithm>

using namespace std;

char a[1001] = "#";
char b[1001] = "#";
int dp[1005][1005] = { 0 };

int main()
{
while (~scanf("%s%s", a + 1, b + 1))//加上~,不然超时,醉了
{

int a_len = strlen(a) - 1;
int b_len = strlen(b) - 1;

for (int i = 1; i <= a_len; i++)
{
for (int j = 1; j <= b_len; j++)
{
if (a[i] == b[j])
dp[i][j] = dp[i - 1][j - 1] + 1;
else
dp[i][j] = max(dp[i][j - 1], dp[i - 1][j]);
}
}

printf("%d\n", dp[a_len][b_len]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: