您的位置:首页 > 其它

POJ 3067 Japan (树状数组)

2016-03-20 23:24 411 查看
Japan

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 24701Accepted: 6650
Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast
are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of
crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the
East coast and second one is the number of the city of the West coast.
Output

For each test case write one line on the standard output:

Test case (case number): (number of crossings)
Sample Input
1
3 4 4
1 4
2 3
3 2
3 1

Sample Output
Test case 1: 5

Source

Southeastern Europe 2006
大体题意:

日本东海岸有N个城市,西海岸有M个城市,两边有桥相连,接下来告诉你K个桥,连接东西哪两个城市!输出,所有桥的交点个数,(最多有两个桥交于一点)

思路:

通过这个题了解了 树状数组,虽然是个模板,请教了学长后,感觉本题向树状数组转换不太好想。

建立一个结构体,表示一个桥,包括左边界l(东),和右边界r(西),输入完毕后给桥排序,先按l排序,l相同按r排序,(相当于给右边界r构建树状数组)。

这个题和普通的不太一样,C数组开始要清零,C数组的值表示比r大的数组和,有点乱,举个例子:

拿样例分析:排序后桥的顺序应该是(1,4)(2,3)(3,1)(3,2),1连接着4,所以C[4] ++; 然后在是2连接着3,则比3大的4有一个点,所以又多了一个点ans+=sum[4] - sum[3];以此类推!

这样直接遍历每一个桥,ans += sum(m) - sum (y)即可!

有几个坑:K的数据范围没说 开到100W才不RE的,然后又是WA,才发现是要开long long 的 int 过不了!

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll n,m,k;
const ll maxn = 1000000 + 10;
ll c[maxn];
struct coast{
ll l,r;
bool operator < (const coast & a) const {
return l < a.l || (l == a.l && r < a.r);
}
}coa[maxn];
ll lowbit(ll x){
return x&-x;
}
void add(ll x,ll d){
while(x <= m){
c[x]++;
x+=lowbit(x);
}
}
ll sum(ll x){
ll ans=0;
while(x > 0){
ans+=c[x];
x-=lowbit(x);
}
return ans;
}
int main(){
ll T,cnt=0;
scanf("%I64d",&T);
while(T--){
memset(c,0,sizeof(c));
scanf("%I64d%I64d%I64d",&n,&m,&k);
for (ll i = 0; i < k; ++i)
scanf("%I64d%I64d",&coa[i].l,&coa[i].r);
sort(coa,coa+k);
ll ans = 0;
for (ll i = 0; i < k; ++i){
add(coa[i].r,1);
ans += sum(m)-sum(coa[i].r);
}
printf("Test case %I64d: %I64d\n",++cnt,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: