您的位置:首页 > 其它

SDAU贪心专题 06 电梯

2016-03-20 15:44 316 查看
1:问题描述

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2

3 2 3 1

0

Sample Output

17

41

2:大致题意

这个题挺简单的。一个电梯,上一层需要6秒,下一层需要4秒,在指定楼层停留5秒。

输入指令,求时间。虽然这个题出现在贪心专题里面,但个人认为并没有用到贪心算法。一步一步算就行了。没有牵扯到最优解的问题。

3:思路

一次一次求即可,每次记录相应的楼层。下次输入指令时,先判断是上楼还是下楼。

当时考虑到,如果连续输入2个相同的指令的话,就应该不用停留了。因此wa一次。其实是需要加上5秒的。

4:感想

签到题。当时和某窦一起做的,虽然ac的比他早,但由于wa一次被罚时了��。这套题一直都是和某窦一起做的。我们说好要一起完成费老师的夙愿那(●’◡’●)。

5:ac代码

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
using namespace std;
int ww[105];
int main()
{
int n,i,k,j,z;
while(cin>>n&&n!=0)
{
int time=0;
memset(ww,0,sizeof(ww));
for(i=0;i<n;i++)
{
cin>>ww[i];
if(i==0)
{
time+=6*ww[i]+5;
}
else
{
if(ww[i]>ww[i-1]) time+=6*(ww[i]-ww[i-1])+5;
else time+=4*(ww[i-1]-ww[i])+5;
}
}
cout<<time<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: