您的位置:首页 > 其它

ZOJ2339 Hyperhuffman 优先队列

2016-03-19 17:32 351 查看
Hyperhuffman
Time Limit: 5 Seconds      Memory Limit: 32768 KB

You might have heard about Huffman encoding - that is the coding system that minimizes the expected length of the text if the codes for characters are required to consist of an integral
number of bits.
Let us recall codes assignment process in Huffman encoding. First the Huffman tree is constructed. Let the alphabet consist of N characters, i-th of which occurs Pi times
in the input text. Initially all characters are considered to be active nodes of the future tree, i-th being marked with Pi. On each step take two active nodes with smallest marks, create the new node, mark it with the sum of the considered
nodes and make them the children of the new node. Then remove the two nodes that now have parent from the set of active nodes and make the new node active. This process is repeated until only one active node exists, it is made the root of the tree.
Note that the characters of the alphabet are represented by the leaves of the tree. For each leaf node the length of its code in the Huffman encoding is the length of the path from the
root to the node. The code itself can be constrcuted the following way: for each internal node consider two edges from it to its children. Assign 0 to one of them and 1 to another. The code of the character is then the sequence of 0s and 1s passed on the way
from the root to the leaf node representing this character.
In this problem you are asked to detect the length of the text after it being encoded with Huffman method. Since the length of the code for the character depends only on the number of
occurences of this character, the text itself is not given - only the number of occurences of each character. Characters are given from most rare to most frequent.
Note that the alphabet used for the text is quite huge - it may contain up to 500 000 characters.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank
line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.

Input
The first line of the input file contains N - the number of different characters used in the text (2 <= N <= 500 000). The second line contains N integer numbers Pi - the number
of occurences of each character (1 <= Pi <= 109, Pi <= Pi+1 for all valid i).

Output
Output the length of the text after encoding it using Huffman method, in bits.

Sample Input
1

3

1 1 4

Sample Output
8

求haffuman编码问题。
#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

long long a,b,x;

priority_queue< long long,vector<long long>, greater<long long> >pq; //优先队列默认是从大到小顺序

int main()
{
int T,n;
scanf("%d",&T);
for(int ca=1;ca<=T;ca++)
{
while(!pq.empty())
pq.pop();

scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%lld",&x);
pq.push(x);
}
long long ans=0;
for(int i=0;i<n-1;i++)
{
a=pq.top();
pq.pop();
b=pq.top();
pq.pop();

long long sum=a+b;
ans+=sum; //把两数求和相加
pq.push(sum);

//cout<<"sum="<<sum<<" "<<"ans="<<ans<<endl;
}

if(ca!=1)
puts("");

printf("%lld\n",ans);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: