您的位置:首页 > 其它

PAT (Advanced Level) Practise 1065 A+B and C (64bit) (20)

2016-03-18 16:45 423 查看


1065. A+B and C (64bit) (20)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false

故意卡在longlong的上限上,可以感受到出题人满满的恶意,先读在字符串里,然后去掉符号用unsignedlonglong来存,剩下的就是判断符号和越界的问题。
#include<cmath>
#include<queue>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
typedef unsigned long long ull;
const int mod = 1e9 + 7;
const int maxn = 1e3 + 10;
const ull INF = ((ull)1 << 63);
int T, t;
char s[maxn];
ull a, b, c;

bool check()
{
int f1 = 0, f2 = 0, f3 = 0;
scanf("%s", s); f1 = s[0] == '-'; sscanf(f1 ? s + 1 : s, "%llu", &a);
scanf("%s", s); f2 = s[0] == '-'; sscanf(f2 ? s + 1 : s, "%llu", &b);
scanf("%s", s); f3 = s[0] == '-'; sscanf(f3 ? s + 1 : s, "%llu", &c);
if (a == INF && a == b && f1 == f2) return !f1;
if (f1 == f2) b += a;
else
{
if (f1) if (a > b) { f2 = 1; b = a - b; } else b -= a;
else if (a >= b) { f2 = 0; b = a - b; } else b -= a;
}
return f2 == f3 ? f2 ? b < c : b > c : f2 < f3;
}

int main()
{
scanf("%d", &T);
while (T--)
{
printf("Case #%d: %s\n", ++t, check() ? "true" : "false");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT