您的位置:首页 > 其它

G

2016-03-16 22:33 204 查看
[align=left]Problem Description[/align]
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one
floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

[align=left]Input[/align]
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

[align=left]Output[/align]
Print the total time on a single line for each test case.

 

[align=left]Sample Input[/align]

1 2
3 2 3 1
0

 

[align=left]Sample Output[/align]

17
41

电梯上一层6s下一层4s停5s,单纯的循环求解

代码

#include<iostream>

#include<vector>

using namespace std;

int main()

{

    int n;

    while(cin>>n&&n!=0)

    {    vector<int >v;

        v.push_back(0);

        int result=0;

        int temp;

        for(int i=0;i<n;i++)

        {

            cin>>temp;

             v.push_back(temp);

             }

             for(int i=1;i<n+1;i++ )

             {

                 if(v[i]>v[i-1])

                 {

                     result=result+(v[i]-v[i-1])*6;

                 }

                 else if(v[i]<v[i-1])

                    {

                     result=result+(v[i-1]-v[i])*4;

                 }

             }

              result= result+n*5;

              cout<< result<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: