您的位置:首页 > 其它

HDOJ 1027 Ignatius and the Princess II (DFS全排列)

2016-03-16 08:16 232 查看

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6449    Accepted Submission(s): 3815


[align=left]Problem Description[/align]
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if
you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once
in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"

Can you help Ignatius to solve this problem?

 

[align=left]Input[/align]
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of
file.

 

[align=left]Output[/align]
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

 

[align=left]Sample Input[/align]

6 4
11 8

 

[align=left]Sample Output[/align]

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

题意:求全排列1-n中第m个排列

思路:直接dfs就行

ac代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
#define eps 1e-8
using namespace std;
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
ll powmod(ll a,ll b,ll MOD){ll ans=1;while(b){if(b%2)ans=ans*a%MOD;a=a*a%MOD;b/=2;}return ans;}
double dpow(double a,ll b){double ans=1.0;while(b){if(b%2)ans=ans*a;a=a*a;b/=2;}return ans;}
//head
int n,m,bz,x;
int v[MAXN];
void debug()
{
for(int i=1;i<=n;i++)
if(v[i])
printf("%d ",i);
printf("\n");
}
void dfs(int cnt)
{
int i;
if(bz)
return;
if(cnt==n+1)
{
x++;
//debug();
//printf("x=%d\n",x);
if(x==m)
{
bz=1;
int k=1;
int flag=0;
while(k<=n)
{
for(i=1;i<=n;i++)
if(v[i]==k)
{
if(flag==0)
printf("%d",i),flag=1;
else
printf(" %d",i);
k++;
}

}
printf("\n");
}
return;
}
for(i=1;i<=n;i++)
if(!v[i])
{
v[i]=cnt;
dfs(cnt+1);
v[i]=0;
}
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
mem(v);bz=0;x=0;
dfs(1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: