您的位置:首页 > 其它

hdu1213

2016-03-15 22:06 495 查看
Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5


Sample Output

2
4


题目:

求有多少人互不认识对方(求有多少个集合)

明显的并查集,只需要在查询集合的时候查看当前集合的代表是否被计数过,如果没有就把sum计数加1

#include<iostream>

using namespace std;

const int MAX_SIZE = 1010;

int flag[MAX_SIZE];

class UNION

{

private:

int pre[MAX_SIZE];

public:

void init()

{

for(int i = 0; i< MAX_SIZE; i++)

{

pre[i] = i;

flag[i] = 0;

}

}

int my_find(int x)

{

if(x != pre[x])

pre[x] = my_find(pre[x]);

return pre[x];

}

void my_union(int x, int y)

{

int i = my_find(x), j = my_find(y);

pre[i] = j;

}

};

int main()

{

UNION u;

int t;

int n, m;

int a,b;

int temp;

int sum;

cin>>t;

while(t--)

{

sum = 0;

u.init();

cin>>n>>m;

while(m--)

{

cin>>a>>b;

u.my_union(a, b);

}

for(int i = 1; i <= n; i++)

{

temp = u.my_find(i);

if(!flag[temp])

{

flag[temp]++;

sum++;

}

}

cout<<sum<<endl;

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: