您的位置:首页 > 其它

1718 Rank

2016-03-14 21:47 363 查看
[align=left]Problem Description[/align]
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.

[align=left]Input[/align]
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.

[align=left]Output[/align]
For each test case, output a line giving Jackson’s rank in the class.

[align=left]Sample Input[/align]

20070101
20070102 100
20070101 33
20070103 22
20070106 33
0 0

[align=left]Sample Output[/align]

2

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
int main()
{
int JK,haoma,a[1005],data,k;
while(cin>>JK)
{
k=0;
while(~scanf("%d%d",&haoma,&a[k]))
{
k++;
if(haoma==JK)
data=a[k-1];
if(haoma==0&&a[k-1]==0)
break;
}
sort(a,a+k);
for(int i=0;i<k;i++)
if(data<a[i])
{
data=k-i+1;
break;
}
cout<<data<<endl;
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: