您的位置:首页 > 其它

LightOJ 1370 Bi-shoe and Phi-shoe(素数筛)

2016-03-14 19:42 295 查看
Click Here~~

A - Bi-shoe and Phi-shoe

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu

Submit

Status

Practice

LightOJ 1370

Description

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题目大意:

首先给出T组数据,给一些数ai(第 i 个数),ai这些数代表的是某个数欧拉函数的值,我们要求出数 pi 的欧拉函数值不小于ai。而我们要求的就是这些 pi 这些数字的和sum,而且我们想要sum最小,求出sum至少是多少。

解题思路:

要想找到最小的和 只要我们考虑的是每个pi最小 因为素数的欧拉函数值是素数-1,所以我们只需要找到比ai大的第一个素数就行啦,然后我们就想到素数筛啦 哈哈~~ 其实数据范围是1e6,并不是很大 所以可以直接存下

详见代码:

#include <iostream>
#include <cstring>
using namespace std;
typedef long long LL;
const int MAXN = 1e6+5;
int prime[MAXN];///存素数的
int cnt;///素数的个数
bool p[MAXN];///判断素数滴
void isprime()///素数筛
{
cnt = 0;
memset(p, true, sizeof(p));
p[1] = false;
for(LL i=2; i<MAXN; i++)
{
if(p[i])
{
prime[cnt++] = i;
for(LL j=i*i; j<MAXN; j+=i)
p[j] = false;
}
}
}
///没有用的欧拉函数 白写了~~
///int Eular(int m)
///{
///    int ret = m;
///    for(int i=2; i<m; i++)
///    {
///        if(m%i == 0)
///        {
///            ret -= ret/i;
///            while(m%i)
///                m /= i;
///        }
///    }
///    if(m > 1)
///        ret -= ret/m;
///    return ret;
///}
int main()
{
isprime();
///cout<<prime[cnt-1]<<endl;
LL T, m, num;
cin>>T;
for(int cas=1; cas<=T; cas++)
{
cin>>m;
LL sum = 0;
while(m--)
{
cin>>num;
for(int i=num+1; ; i++)///找到第一个素数
{
if(p[i])
{
sum += i;
break;
}
}
}
cout<<"Case "<<cas<<": "<<sum<<" Xukha\n";
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: