您的位置:首页 > 其它

欢迎使用CSDN-markdown编辑器

2016-03-13 10:51 211 查看
最长子序列问题

Longest Ordered Subsequence

Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB

Total submit users: 2415, Accepted users: 2061

Problem 10001 : No special judgement

Problem description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7

1 7 3 5 9 4 8

Sample Output

4

题目为求输入序列的最长上升子序列,时间复杂度为O(n^2)

算法思路:

1.进行遍历数组,求出每一个元素前的最长子序列长度,将自己计入序列,保存该最大值

2.在此遍历数组,输出最长子序列的最大值

具体实现:

外层循环实现遍历

内层循环查找该元素前的最长子序列的长度

将该元素加入该序列,记录当前元素的最长子序列的长度

C/C++代码:

#include <stdio.h>
int main ()
{
int n,i,j,max=0;
int arr[1000],b[1000];
scanf("%d",&n);
for (i=0;i<n;i++)
{
scanf ("%d",&arr[i]);
b[i]=0;
}

for (i=0;i<n;i++)
{
max=0;
for (j=0;j<n;j++)
{
if ((arr[i]>arr[j])&&(max<b[j])) max=b[j];
}
b[i]=max+1;
}
max=0;
for (i=0;i<n;i++)
if (b[i]>max) max=b[i];
printf("%d",max);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: