您的位置:首页 > 产品设计 > UI/UE

POJ 3061 Subsequence

2016-03-08 20:45 579 查看



http://poj.org/problem?id=3061

Subsequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10903 Accepted: 4513
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3


//这里要 求等于s最小的长度子序列

#include <cstdio>
#include <algorithm>
#define min(a,b) (a<b?a:b)
int arr[100001];
int main()
{
int t;
int s,n;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&s);
for(int i=0;i<n;++i)
{
scanf("%d",arr+i);
}
int i=0,j=0;
int sum=0;
int ans=100010;
while(1)
{
while(i<n&&sum<s)
{
sum+=arr[i++];
}
if(sum<s) //后面没有满足条件的
{
break;
}
ans=min(ans,i-j);
sum-=arr[j++];
}
if(ans>n)
{
printf("0\n");
continue;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: