您的位置:首页 > 其它

1001. A+B Format (20)

2016-03-08 17:27 429 查看
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input
-1000000 9

Sample Output
-999,991

#include<iostream>
#include<iomanip>
using namespace std;
int main(){
int a,b,d=1000000;
int sum=0;
cin>>a>>b;
sum=a+b;
bool head;
if(sum<0){
sum*=-1;
cout<<'-';
}
head=1;
while(d>1){
if(head==1){
if(sum/d){
cout<<sum/d<<',';
head=0;
}
}
else{
cout<<setw(3)<<setfill('0')<<sum/d<<',';
}

sum%=d;
d/=1000;
}
if(head==1)	cout<<sum<<endl;
else	cout<<setw(3)<<setfill('0')<<sum<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: