您的位置:首页 > 产品设计 > UI/UE

poj 3061 Subsequence

2016-03-08 17:08 369 查看
Subsequence

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10902Accepted: 4512
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3
题意:给定长度为n的整数数列以及整数S,求出总和不小于S的连续子序列的长度的最小值,如果解 不存在,输出0.
思路:用sum[]数组存储1到i的和,然后用二分法求长度

代码:

#include<stdio.h>
#include<string.h>
#define M 100010
int a[M],sum[M],s,n;
bool check(int x)
{
for(int i=1;i+x-1<=n;i++)
{
if(sum[i+x-1]-sum[i-1]>=s)
return true;
}
return false;
}
int main()
{
int T,i;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&s);
memset(sum,0,sizeof(sum));
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum[i]+=sum[i-1]+a[i];
}
int l=1,r=n+1;
while(l<r)
{
int mid=(l+r)/2;
if(check(mid))
r=mid;
else
l=mid+1;
}
printf("%d\n",l==n+1?0:l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: