您的位置:首页 > 其它

hdu 5635 LCP Array(BC第一题)

2016-03-08 08:40 176 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5635


LCP Array

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 282 Accepted Submission(s): 79

Problem Description

Peter has a string s=s1s2...sn,
let suffi=sisi+1...sn be
the suffix start with i-th
character of s.
Peter knows the lcp (longest common prefix) of each two adjacent suffixes which denotes as ai=lcp(suffi,suffi+1)(1≤i<n).

Given the lcp array, Peter wants to know how many strings containing lowercase English letters only will satisfy the lcp array. The answer may be too large, just print it modulo 109+7.

Input

There are multiple test cases. The first line of input contains an integer T indicating
the number of test cases. For each test case:

The first line contains an integer n (2≤n≤105) --
the length of the string. The second line contains n−1 integers: a1,a2,...,an−1 (0≤ai≤n).

The sum of values of n in
all test cases doesn't exceed 106.

Output

For each test case output one integer denoting the answer. The answer must be printed modulo 109+7.

Sample Input

3
3
0 0
4
3 2 1
3
1 2


Sample Output

16250
26
0


Source

BestCoder Round #74 (div.2)

#include <iostream>
#include <stdio.h>
using namespace std;

struct Arrow{
int a;
int b;
}arrow[50];//?

int cmp(const void * a,const void *b){
Arrow m = *(Arrow*)a;
Arrow n = *(Arrow*)b;
return m.a-n.a;
}

int create(int i)
{
i=i-2;
printf(">+");
while(i--)
{
printf("-");
}
printf("+>\n");
return 0;
}

int main(){
int t,N,three,four;
scanf("%d",&t);// 0 1 2 3
while(t--)
{
scanf("%d",&N);
for(int Ni=0;Ni<N;Ni++)
{
scanf("%d%d",&arrow[Ni].a,&arrow[Ni].b);
}
qsort(arrow,N,sizeof(arrow[0]),cmp);
for(int Ni=0;Ni<N;Ni++){
for(int i=0;i<arrow[Ni].b;i++){
create(arrow[Ni].a);

}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: