您的位置:首页 > 其它

hdu 1398 Square Coins

2016-03-07 16:28 417 查看
Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are
available in Silverland.

There are four combinations of coins to pay ten credits:

ten 1-credit coins,

one 4-credit coin and six 1-credit coins,

two 4-credit coins and two 1-credit coins, and

one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2

10

30

0

Sample Output

1

4

27
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int a[500],b[500],i,j,k,n;
while (scanf("%d",&n),n)
{
for (i=0;i<=n;i++)
{
a[i]=1;       //赋初值
b[i]=0;
}
for (i=2;i*i<=n;i++)      //根据情况进行变换(i*i<=n)
{
for (j=0;j<=n;j++)
for (k=0;k+j<=n;k+=i*i)
b[k+j]+=a[j];       //这两个for循环将i的一种情况进行了统计
for (j=0;j<=n;j++)
{
a[j]=b[j];       //进行传值,并将b数组清零
b[j]=0;
}
}
printf("%d\n",a
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: