您的位置:首页 > 其它

hdu 5233 Gunner II (map离散化)

2016-03-06 14:04 330 查看
http://acm.hdu.edu.cn/showproblem.php?pid=5233

Gunner II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1756    Accepted Submission(s): 643


[align=left]Problem Description[/align]
Long long ago, there was a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i-th bird stands on the top of the i-th tree. The trees stand in straight line
from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the nearest bird which stands in the tree with height H will falls.

Jack will shot many times, he wants to know which bird will fall during each shot.

 

[align=left]Input[/align]
There are multiple test cases (about 5), every case gives n, m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h[1],h[2],h[3],…,h
which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

All input items are integers.

1<=n,m<=100000(10^5)

1<=h[i],q[i]<=1000000000(10^9)

 

[align=left]Output[/align]
For each q[i], output an integer in a single line indicates the id of bird Jack shots down. If Jack can’t shot any bird, just output -1.

The id starts from 1.

 

[align=left]Sample Input[/align]

5 5
1 2 3 4 1
1 3 1 4 2

 

[align=left]Sample Output[/align]

1
3
5
4
2

HintHuge input, fast IO is recommended.

 
题意:给出每棵树的高度和每次射击的树的高度,如果该树上有鸟,就输出这棵树的下标,可能有同样高度的树,先射击靠近左边的树,找不到该树或者就输出-1;

用map定义一个vector数组,插入数据,直接输出就ok了

比赛的时候不会用map函数,之后学习了map函数,感觉好简单

#include <iostream>
#include <cstdio>
#include <map>
#include <string>
#include <algorithm>
#include <vector>

using namespace std;

#define N 110000

int main ()
{
int n, m, h
, q;

map <int, vector <int> > mp;

while (scanf ("%d %d", &n, &m) != EOF)
{
mp.clear();

for (int i=1; i<=n; i++)
scanf ("%d", &h[i]);

for (int i=n; i>=1; i--)///倒着存入数据
mp[h[i]].push_back (i);

for (int i=0; i<m; i++)
{
scanf ("%d", &q);

if (mp[q].size() > 0)
{
printf ("%d\n", mp[q].back());
mp[q].pop_back();
}
else puts ("-1");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: