您的位置:首页 > 其它

UVA--1211(二分+前缀和)

2016-03-05 16:50 260 查看
D - 幸福呢。
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
3061

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5


Sample Output

2
3


题意:给你一串长为n的序列,求长度最短的连续序列,使他们和大于S,输出该长度,若不存在,输出0

分析i二分长度+前缀之和可以轻松搞定

代码如下:

#include<stdio.h>
int n,S;
int a[100010];
int ans;
void input(){
int i;
for(i=1;i<=n;i++){
scanf("%d",&a[i]);
a[i]=a[i-1]+a[i];//前缀之和
}
}
bool OK(int m){
int i,temp;
for(i=1;i<=n-(m-1);i++){
temp=a[i+(m-1)]-a[i-1];//长度为m
if(S<temp)return true;
}
return false;
}
void slove(){
int l=1;
int r=n;
int m;
while(l<r){
m=(l+r)/2;
if(OK(m))r=m;//r保存可以的长度
else l=m+1;
}
ans=r;
}
int main(){
int t;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&S);
input();
slove();
if(ans==n)printf("0\n");
else printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: