您的位置:首页 > 其它

全排列 hdoj1027

2016-03-05 15:47 239 查看
Problem Description

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, “I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too.” Ignatius says confidently, “OK, at last, I will save the Princess.”

“Now I will show you the first problem.” feng5166 says, “Given a sequence of number 1 to N, we define that 1,2,3…N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it’s easy to see the second smallest sequence is 1,2,3…N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It’s easy, isn’t is? Hahahahaha……”

Can you help Ignatius to solve this problem?

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub’s demand. The input is terminated by the end of file.

Output

For each test case, you only have to output the sequence satisfied the BEelzebub’s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input

6 4

11 8

Sample Output

1 2 3 5 6 4

1 2 3 4 5 6 7 9 8 11 10

**由于是按字典序列进行全排序,首先我先将程序运行结果演示一下

1 2 3 4 5 6

1 2 3 4 6 5 先从最后将两个互换,由于5<6直接互换就行

1 2 3 5 4 6 由于6>5,所以从4跟后面最小的一个数进行互换,然后将后面两个数排序

大致就是按这种思路进行全排列**

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int sequence[1100];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)==2)
{
for(int i=1;i<=n;i++)
{
sequence[i]=i;
}
for(int i=2;i<=m;i++)
{
int j=n;
while(sequence[j]<sequence[j-1])
{
j--;
}
for(int k=n;k>=j;k--)
{
if(sequence[k]>sequence[j-1])
{
int tem=sequence[k];
sequence[k]=sequence[j-1];
sequence[j-1]=tem;
break;
}

}
sort(sequence+j,sequence+n+1);
}
for(int i=1;i<n;i++)
{
printf("%d ",sequence[i]);
}
printf("%d\n",sequence
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: