您的位置:首页 > 产品设计 > UI/UE

poj Subsequence 3061 (高效&DP)

2016-03-05 13:48 357 查看
Subsequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10880 Accepted: 4497
Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements
of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case,
separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3

//题意:

给你两个数n,m,n表示有n个数,m表示目标分数,问最短的连续数列的和>=m,求出这个数。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#define INF 0x3f3f3f3f
#define ll long long
#define N 100010
using namespace std;
ll sum
;
int main()
{
int t,n,m,a;
int i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
{
scanf("%d",&a);
sum[i]=sum[i-1]+a;
}
int mm=n+1;
for(i=j=1;j<=n;j++)
{
if(sum[j]-sum[i-1]<m)
continue;
while(sum[j]-sum[i]>=m)
i++;
mm=min(mm,j-i+1);
}
if(mm==n+1)
printf("0\n");
else
printf("%d\n",mm);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: