您的位置:首页 > 其它

bzoj 3940(ac自动机)

2016-03-03 20:52 162 查看

3940: [Usaco2015 Feb]Censoring

Time Limit: 10 Sec Memory Limit: 128 MB

Submit: 157 Solved: 82

[Submit][Status][Discuss]

Description

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty
of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest
issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his
cows not see (clearly, the magazine is in need of better editorial oversight).
FJ has taken all of the text from the magazine to create the string S of length at most 10^5 characters.
He has a list of censored words t_1 ... t_N that he wishes to delete from S. To do so Farmer John finds
the earliest occurrence of a censored word in S (having the earliest start index) and removes that instance
of the word from S. He then repeats the process again, deleting the earliest occurrence of a censored word
from S, repeating until there are no more occurrences of censored words in S. Note that the deletion of one
censored word might create a new occurrence of a censored word that didn't exist before.
Farmer John notes that the censored words have the property that no censored word appears as a substring of
another censored word. In particular this means the censored word with earliest index in S is uniquely
defined.Please help FJ determine the final contents of S after censoring is complete.
FJ把杂志上所有的文章摘抄了下来并把它变成了一个长度不超过10^5的字符串S。他有一个包含n个单词的列表,列表里的n个单词
记为t_1...t_N。他希望从S中删除这些单词。
FJ每次在S中找到最早出现的列表中的单词(最早出现指该单词的开始位置最小),然后从S中删除这个单词。他重复这个操作直到S中
没有列表里的单词为止。注意删除一个单词后可能会导致S中出现另一个列表中的单词
FJ注意到列表中的单词不会出现一个单词是另一个单词子串的情况,这意味着每个列表中的单词在S中出现的开始位置是互不相同的
请帮助FJ完成这些操作并输出最后的S


Input

The first line will contain S. The second line will contain N, the number of censored words. The next N lines contain the strings t_1 ... t_N. Each string will contain lower-case alphabet characters
(in the range a..z), and the combined lengths of all these strings will be at most 10^5.
第一行包含一个字符串S
第二行包含一个整数N
接下来的N行,每行包含一个字符串,第i行的字符串是t_i


Output

The string S after all deletions are complete. It is guaranteed that S will not become empty during the
deletion process.

一行,输出操作后的S



Sample Input

begintheescapexecutionatthebreakofdawn

2

escape

execution

Sample Output

beginthatthebreakofdawn

解题思路:裸的ac自动机,打了个优化的ac自动机。

#include<cstdio>

#include<iostream>

#include<algorithm>

#include<cstring>

using namespace std;

char s[110000];

char c[110000];

int ch[110000][26];

int size;

int sig[110000];

int q[110000];

int fail[110000];

int ng[110000];

void build()

{

int lg=strlen(c); int now=0;

for (int i=1;i<=lg;++i)

{

if (ch[now][c[i-1]-'a']!=0) now=ch[now][c[i-1]-'a'];else

{

++size; ch[now][c[i-1]-'a']=size; now=size;

}

}

sig[now]=lg;

}

void getfail()

{

int tail=0; int head=0; ++tail; q[tail]=0;

while (head<tail)

{

++head; int now=q[head];

for (int i=0;i<26;++i)

{

int v=ch[now][i];

if (v==0)

{

ch[now][i]=ch[fail[now]][i];

continue;

}

if (!now)fail[v]=0;else

fail[v]=ch[fail[now]][i];

++tail; q[tail]=v;

}

}

}

int main()

{

freopen("data.in","r",stdin);

freopen("data.out","w",stdout);

scanf("%s",s);

int n;

scanf("%d",&n);

for (int i=1;i<=n;++i)

{

scanf("%s",c);

build();

}

getfail();

int len=strlen(s); int top=0;

for (int i=1;i<=len;++i)

{

ng[i]=ch[ng[q[top]]][s[i-1]-'a'];

q[++top]=i;

top-=sig[ng[i]];

}

for (int i=1;i<=top;++i)

{

cout<<s[q[i]-1];

}

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: